20100129

날숨/잡담 2010.01.29 15:20

# 실수 1
회사에서 사용하는 JDK 버전을 1.4에서 6.0으로 올렸다.
이클립스에서 컴파일러와 톰캣의 모든 설정을 다 해줬다고 생각했는데,
자꾸 tomcat이 자신이 1.4라고 인식하고 bad class version 에러 메세지를 띄우기 시작했다.
문제는 tomcat/common/lib에 직접 복사해서 넣어둔 JDK 1.4 버전의 tools.jar 때문
환경변수의 CLASSPATH에 JAVA_HOME/lib/tools.jar를 제대로 넣어주면 tomcat/common/lib에 tools.jar를 직접 복사해 넣을 필요가 없다. 만약 CLASSPATH 설정과 tools.jar 복사를 같이 해 놓으면 톰캣은 자신의 lib 폴더에 있는 tools.jar를 먼저 찾는다.
아 ㅠㅠㅠ 내 시간..

덧. 지금 해보니 CLASSPATH를 제대로 설정해줘도 톰캣에서 tools.jar를 제대로 찾지 못한다. JSP를 컴파일 하지 못한다는 에러 메세지가 자꾸 떠서 그냥 tools.jar를 복사해서 넣어 버렸다.

# 실수 2
어제 디비 SQL문 작업을 하다가 자꾸 malformed SQL92 string 이라는 에러 메세지를 봤다.
정말 별 쇼를 다 하다가 찾아보니 닫는 괄호(')')를 대괄호('}')로 해 버렸었던 것.
이런건 정말 찾기 힘들다. 전에도 이런 실수를 했었는데, 또 저질러 버렸다. ㅠ
저작자 표시 비영리
신고
posted by purecolor